allure安装遇到的问题

问题

安装allure(版本号:2.13.1)后,查看是否安装成功,页面一直提示java.lang.UnsupportedClassVersionError: io/qameta/allu(大概意思就是版本不支持)
image

解决办法

1、将jdk更新为1.8版本(之前我用的是jdk1.7,另外,电脑中可存在多个版本jdk,只修改环境变量就可以);
官网下载地址:https://www.oracle.com/java/technologies/javase-jdk8-downloads.html
2、更新环境变量,修改JAVA_HOME变量值。
3、重启gitbash、pycharm就可以了
image

关闭