测试人社区

selenium 安装遇到的问题


查问题中
当前的chrome 版本是:
下载的镜像是

记录:
在安装环境的时候,发现自己必须把chromedriver 放到usr/local/bin下面 再source 才可以运行driver

这是warning,影响你使用selenium吗,试试selenium的脚本能不能跑通呢

印象中chromedriver的版本是不能大于浏览器版本的 你这个貌似超前了 不过chrome最新版是138了 你更新一下浏览器试试看

根据当前chrome的版本下载安装了相应的driver,那如果后面chrome升级了,是不是这个driver就不能用了,需要另外下载与chrome版本对应的driver,是吗?

chromedriver可以落后(版本并不是一一对应的,chromedriver的版本数量远远要小于频繁更新的chrome版本)但是印象中是不能超前的 虽然chromedriver老版本也能用,但是因为每个版本都在修复一些BUG什么的,也别用太老的版本就是了。。不然有时候会有比较诡异的BUG~

哦,清楚了,谢谢!

试了下载最新的chromedriver 还是有这个warnning

这个chromedriver并不是拿来直接运行的,所以你不用考虑这种情况下的提示,通过selenium去调用的时候没有报错就行了

好的,实际去跑了脚本可以跑通,谢谢老师

不影响,谢谢老师,脚本可以跑通



错误页面比较长,通过制定driver路径解决问题,一定不要忘了路径前面的r