JUnit5测试框架

代码演练地址

IDEA安装

xUnit测试框架

JUnit4

JUnit5

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>

    <groupId>com.ceshiren.hogwarts</groupId>
    <artifactId>Java3</artifactId>
    <version>1.0-SNAPSHOT</version>

    <properties>
        <aspectj.version>1.8.10</aspectj.version>
        <maven.compiler.source>1.8</maven.compiler.source>
        <maven.compiler.target>1.8</maven.compiler.target>
    </properties>


    <dependencies>
        <dependency>
            <groupId>org.junit.jupiter</groupId>
            <artifactId>junit-jupiter</artifactId>
            <version>RELEASE</version>
            <scope>compile</scope>
        </dependency>
        <dependency>
            <groupId>com.fasterxml.jackson.core</groupId>
            <artifactId>jackson-databind</artifactId>
            <version>2.9.8</version>
        </dependency>
        <dependency>
            <groupId>com.fasterxml.jackson.dataformat</groupId>
            <artifactId>jackson-dataformat-yaml</artifactId>
            <version>2.9.9</version>
        </dependency>

        <dependency>
            <groupId>io.qameta.allure</groupId>
            <artifactId>allure-junit5</artifactId>
            <version>RELEASE</version>
            <scope>test</scope>
        </dependency>


    </dependencies>


    <build>
        <plugins>
            <plugin>
                <artifactId>maven-surefire-plugin</artifactId>
                <version>2.21.0</version>
                <configuration>
                    <testFailureIgnore>false</testFailureIgnore>
                    <argLine>
                        -javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
                    </argLine>
                    <systemProperties>
                        <property>
                            <name>junit.jupiter.extensions.autodetection.enabled</name>
                            <value>true</value>
                        </property>
                    </systemProperties>
                </configuration>
                <dependencies>
                    <dependency>
                        <groupId>org.junit.platform</groupId>
                        <artifactId>junit-platform-surefire-provider</artifactId>
                        <version>1.2.0</version>
                    </dependency>
                    <dependency>
                    <groupId>org.aspectj</groupId>
                    <artifactId>aspectjweaver</artifactId>
                    <version>${aspectj.version}</version>
                    </dependency>
                </dependencies>
            </plugin>
            <plugin>
                <groupId>io.qameta.allure</groupId>
                <artifactId>allure-maven</artifactId>
                <version>2.10.0</version>
                <configuration>
                    <reportVersion>2.4.1</reportVersion>
                </configuration>
            </plugin>
        </plugins>
    </build>


</project>

allure命令

allure serve allure-results/
allure  generate allure-results/ -o /tmp/allure
python3 -m http.server

套件

  • 标签

测试用例调度

maven surefire插件
https://maven.apache.org/surefire/index.html

https://maven.apache.org/surefire/maven-surefire-plugin/index.html

占楼备用

.。

环境配置完成

好奇怪,不知道为什么会报compiler error。
默认似乎是jdk1.5. 当时只有demotestcase1这一条用例。
然后增了第二个用例 – assertAllTestCase, 因为用到了assertall,需要支持lambda,然后修改了,project-》open module setting 的language level 为 8 如下图


再回来编译就出错了。

尝试:
1),注释掉了第二个测试用例,和第一个测试用例中的assertEquals;如下图。
尝试编译运行失败。如下图。

2), 修改open module settings, 从8 修改到5.。。
尝试编译运行。 成功了。。。。

所以请教,为什么更改为1.8 之后,编译失败?是不是还有哪里设置的不对?
一直使用eclipse,用IDEA 较少,是不是还有哪里的设置不对?


我也遇到了百度了一下

1 Like

赞!!! 解决了!! 非常感谢! 917719801 【大拇哥】【大拇哥】
附图给后来者参考:

我也是这样解决的


有可能是缓存。最有效的就是重建一个项目,一开始就把jdk和编译选成1.8

环境的雷暂时是趟过了

ExtentReport

AllureReport

Jenkins查看报告:

底子很差,第一次交作业,虽然折腾很久,值了
1.差点又忘了IJ怎么连远程github


2.踩坑报告总是空,原因是我不应该用allure serve target/allure-results
mvn clean test 后用 allure sever就正常出报告了

3.趁着服务器还没过期,用jenkins跑一把

环境配置好了

占楼

环境配置完成

File>Setting>Java Compiler 里面的 project bytecode version 也改成 8

关闭