启动Appium,填上appPackage、appActivity启动应用报错

Android:10,python:3.7
不填上appPackage、appActivity启动Appium没有问题;

填上这两项就启动不起来,不知道是什么原因,报错原因如下:


提示你appPackage、appActivity,找错了。

这个查找的不对吗?
一个是包名 一个是appActivity

获取任务列表:adb shell dumpsys activity activities
获取appPackage和appActivity:adb logcat | grep -i displayed
在当前页面,获取appPackage和appActivity : adb shell dumpsys window | grep mCurrent

如果还获取不到,可以问下开发

用你的办法获取到了也还是一样

我也碰到过获取失败的情况,有些没办法,我这边是问开发的

嗯嗯 弄好的 是appActivity 不对
谢啦

不客气,好了就行

后面也可以试试这个方法。
- Mac/Linux:adb logcat |grep -i activitymanager
- Windows:adb logcat |findstr /i activitymanager

看下这个有参考价值没,同学

1 Like

image
请问这个报错是啥问题?

aapt d badging apk路径 | grep -E “package|launchable-activity” 试下,我写错了

1 Like
关闭